On-Premises: cannot connect with Elasticsearch


When I start a Space in Kubernetes, Space and Package pods cannot connect to elasticsearch. 

It looks like self signed certificate problem. 

I checked to https://space-support.jetbrains.com/hc/en-us/community/posts/6966335335314, https://grumpytechie.net/2020/02/25/adding-custom-root-ca-certificates-to-debian/

but the problem is not solved.

I try to change elasticsearch's ssl disabled, then it goes OK status.

but I wnat to use self-signed certificate. 

How can I do?



I use minIO, but log shows me that it try to connect AWS S3. How can I fix it? (Package connected well with minIO)

here is my values.yaml.


Etkim, talking about the first question, could you please clarify what's meant by "the problem is not solved"? Have you tried building your own Space images with the custom CA certificates included as it's described in the thread you mentioned? 


Etkim, as for the second one, could you double-check that the object storage configs are specified correctly for all Space services in the values.yaml file?



Elasticsearch is set to use the API using SSL by default, and a self-signed certificate for this is built into the Elasticsearch Cloud on Kubernetes version.

However, Space seems to use HTTP when communicating with Elasticsearch, which caused a connection reset.

In the end, after changing to not use SSL in Elasticsearch, I was able to confirm that it works normally.

Is it possible to configure to use SSL communication?
If it could be, I expect that communication between the two products will be possible if they are registered with a trusted certificate as used in the two links below as I mentioned.

- https://space-support.jetbrains.com/hc/en-us/community/posts/6966335335314
- https://grumpytechie.net/2020/02/25/adding-custom-root-ca-certificates-to-debian/

Oh, and minIO works just fine!

Thanks! :)


Please sign in to leave a comment.