Has someone managed to get a push restriction regular expressions to work?


As the subject says, any luck with regexes on anyone on this forum?

I've tried the simple (DEAD|BEEF)-\d+ which, to my, and ripgrep's, understanding should match a string: ‘fix: DEAD-1337 Trigger a response’. But no.

Oh man, how frustrating my endeavour has been with setting up Space. Should've voted for GitLab…


I'm confused by this also. We seem to have an alternating capturing group in common, but I really don't think coming up with a minimal reproduction is worth it, because we don't even know what regex engine is in use. Aren't these things usually specified in documentation?


I filed a ticket via their support request channel about this issue. From there I got the answer:

Your regex must match the entire string. In the example case, this worked: .*(DEAD|BEEF)–\d+ .*

My guess is, as they are the Kotlin company, that they're using the stock JVM RegEx class, and its `matches()` function. I, personally, would've used `find()` function, i.e. substring match.


Please sign in to leave a comment.