Git SSH -- Permission denied (publickey)


I've tried to get Git working over SSH to  no avail. I have set my public key into my preferences and still it fails. I tried my basic test:

ssh -Tv space.instance

The result contains a peculiar line:

debug1: Next authentication method: publickey
debug1: Offering public key: /Users/juha/.ssh/spaced-out ED25519 SHA256:vXtQEPyX9zJNqI… explicit agent
debug3: send packet: type 50
debug2: we sent a publickey packet, wait for reply
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try. Permission denied (publickey).

The odd line is the “type 51” one. If I try the same test on our Bitbucket, the corresponding line, and the line after that, contains:

debug3: receive packet: type 60
debug1: Server accepts key: /Users/juha/.ssh/spaced-out ED25519 SHA256:vXtQEPyX9zJNqI… explicit agent

Are there some flags I could use to turn on detailed logging into vcs, and space? Neither log anything related to a failed connection.

One thing to note: I'm running an on-premises installation with the docker composition converted to Podman systemd containers.

1 comment

There possibly was some cruft in some container volumes. This problem sorted itself out once I razed all volumes and started a fresh set of containers.


Please sign in to leave a comment.