Problem with the Docker command from Space to import Youtrack issues

Hello, I'm working on a project, and I'm using Space for my team to develop and Youtrack to manage the project. I want to integrate Space and Youtrack so that my issues are synced on both platforms. I've connected Space to Youtrack with no problem, but the Docker command generated from Space to connect to Youtrack is not working. Every time I run the command, the first four chunks are idling, while the last two completely download. The error message is as follows:

docker: error parsing HTTP 403 response body: invalid character '<' looking for beginning of value: "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n<Error><Code>AccessDenied</Code><Message>User: arn:aws:sts::966530686581:assumed-role/prod-pkg-registry-green-ecsTaskRole/8df8639de29f40bcac311a54e799f04a is not authorized to perform: kms:Decrypt on resource: arn:aws:kms:eu-west-1:966530686581:key/**KEY** because no resource-based policy allows the kms:Decrypt action</Message><RequestId>0PPCNVP5E4TN2GKP</RequestId><HostId>D4bTHtHezix+OTyY1ZOaLP4PmEQUKkf8Jp+h+BmkTi/u9JDwYsI53Apb9+ovugxIVq24yj+F3vk=</HostId></Error>".

The command that I run from Space is as follows:

docker run  
    --importSource YouTrack  
    --youtrackQuery "q=project:%20STEM%2BC"  
    --youtrackToken <**MY-YOUTRACK-TOKEN**>  
    --spaceToken <**MY-SPACE-TOKEN**>
    --spaceProject key::MAIN  
    --status "Identified::Open"  
    --status "In Progress::In progress"  
    --status "Ready For Review::Ready For Review"  
    --status "In Review::In Review"  
    --status "Done::Done"  

Niklas Karcher had the same issue here, but running the following command seemed to work for them. 

docker run

I've tried this but I still get the same error.


Please sign in to leave a comment.