Space OnPremise: Self-hosted docker worker on different host does not work - network declared as external, but could not be found


I hope that you can help me understand how to start a worker on a different host than the space installation.

I have deployed Space OnPremise with docker-compose and it works. However I have a problem with adding a self-hosted worker. If I add the self hosted worker to the same docker-compose file it just works like a charm. 

What I want to do is to run the worker on a totally different machine. I can start the worker without problems, it also connects to space and shows healthy. But every time the .space.kts script is processed I run into the following error message:

Failed to start: Compose up finished with exit code: 1. Output: option '--no-ansi' is DEPRECATED ! Please use '--ansi' instead. network space-on-premises_backend-data declared as external, but could not be found.

space-on-premises_backend-data is the network that has been declared in the docker-compose file of Space itself.

Does anybode know how to get around that issue? I really do not want to run the self hosted worker on the same machine. I also tried running the binary instead, but I run into exactly the same issue.


Hello Michael Huber!

Could you please try to create docker network on the worker by running the below command and check if the issue still persists?

docker network create space-on-premises_backend-data


Hello Oleg,

thanks for your response! That solved the problem. I additionally needed to change minio to make it available from the remote worker host and change the URL in the space config accordingly, but now it works


Please sign in to leave a comment.