Attempt to use a database from another organization

Hey all,
trying to minor update on-prem version
get error 

circlet.server.a.b: Attempt to use a database from another organization or organization database is corrupted; current organization ID = 97657209032309339, database organization ID = 8023463383357280574

the green row was in the table,             
I tried to fix it by deleting :(

i dont think this error about version updating

on spacedb.neworganization table id of organization is 8023463383357280574. i think i should change it but i dont know how


yeap! i`m updated  id of organization on spacedb.neworganization table and its work


I got the same error. Then i tried your solution:

UPDATE spacedb.neworganization SET id = [NEW_ID] WHERE id = [OLD_ID];

But here this error occurs:

[42883] ERROR: function gen_id_v2(unknown, integer, boolean) does not exist Hinweis: No function matches the given name and argument types. You might need to add explicit type casts. Wobei: PL/pgSQL function spacedb.trg_fun_auto_etag_neworganization_auto_etag() line 3 at assignment

Can you tell me how you did this id update?


Hello, I had the same error as Pstein too.

And when I tried 
UPDATE spacedb.neworganization SET id = [NEW_ID] WHERE id = [OLD_ID];
I had the exact same error as you Andreas Klinger

I solved this problem by modifying the code of the spacedb.trg_fun_auto_etag_neworganization_auto_etag() triggrer...
You have to replace
(SELECT GEN_ID_V2('id_seq_neworganization_auto_etag', -1869247672, true)
(SELECT spacedb.GEN_ID_V2(CAST('spacedb.id_seq_neworganization_auto_etag' AS regclass), -1869247672, true))


Hello folks, thanks for sharing this information with us. In fact, the organization ID should stay the same during the upgrade process, and this issue is not supposed to appear. Could you kindly elaborate on the steps you followed which caused this? Thanks!


I also followed the "Mayor Updates" (Docker Compose installation) steps in


i`m  disabled db triggers before update =D
i think it was because we change license key from beta to free license 
orgId on spacedb.neworganization wont updated


Hello everyone, thanks for your cooperation. We managed to find the root cause of the issue: step 9 (adding `-Dcirclet.organization.domain=jetbrains` to the JAVA_OPTS) is no longer needed for the 2023.2.0 version. We'll update the guide correspondingly.


Please sign in to leave a comment.