Spaces Webhook Endpoint with Self-Signed Certificate Not Working

- Created https server using self signed cert in a VPS.

- Added endpoint url to webhook in a jetbrains spaces app.

- Turned off "Verify SSL certificate".

- Click Test Endpoint.

- Check recent deliveries

- Status says 

An error occurred during sending request: SSLHandshakeException

Caused by: CertificateException
- Tested endpoint on GitHub Webhook, endpoint works.
0
7 comments
Avatar
Oleg Beriashvili

Kenje4090, Hi!

Could you please clarify if the Application -> Endpoint settings were also adjusted? Have you specified the endpoint URL and turned off the SSL certificate verification there? 

0

Hello oleg, thanks for the response.

- Yes "Verify SSL certificates" in endpoint tab under endpoint url was also disabled.
- I specified the same endpoint in the endpoint tab too.
- Also unchecked the SSL client certificate below.

0
Avatar
Oleg Beriashvili

Kenje4090,

I just tried to give a quick attempt to verify how the "Verify SSL certificates" option works with a dummy service and everything looks OK. 

Could you please share a screenshot of a failed attempt from the "Recent Deliveries" tab of the Space webhook? If there is sensitive data that you would like to avoid exposing here, feel free to contact us via support request: http://jb.gg/space-support 

Also, just in case, could you please try to add the self-signed certificate to "Space -> Administration -> Trusted Certificates" and let me know if this makes any difference? 

 

0

Ok so if I turn on "Verify SSL Cert" and no SSL cert in trusted certs, I get 

An error occurred during sending request: SSLHandshakeException
Caused by: ValidatorException

If I turn off "Verify SSL Cert", I get

An error occurred during sending request: SSLHandshakeException
Caused by: CertificateException

Then I added cert in Administration -> Trusted Certificates, Test endpoint with "Verify SSL Cert" on and off gives the same error in recent deliveries

An error occurred during sending request: SSLHandshakeException
Caused by: CertificateException


When SSL Verification is disabled, it's weird since it still gives CertificateException. 

Note: I tested the same https endpoint on github again, and it worked when I disabled SSL Verification there.

0
Avatar
Oleg Beriashvili

Kenje4090

Thank you for trying this!

Could you please tell me more about the network setup used in the VPS server? Is your destination server behind a load balancer or a proxy? 

0

The destination server isn't behind a load balancer or proxy. Endpoint is the server's global static IP address. The VPS is a fully dedicated machine running a simple HTTPS golang service.

Oh on https server's end, it's getting "TLS handshake error from *****: EOF" errors when I test endpoint from spaces.

0
Avatar
Oleg Beriashvili

Kenje4090

Our Development team will need to take a closer look at this issue. Feel free to subscribe to the YT ticket below to get further updates. If any new data needs to be shared, please post it directly in YT:

https://youtrack.jetbrains.com/issue/SPACE-18811/Spaces-Webhook-Endpoint-with-Self-Signed-Certificate-Not-Working

0

Please sign in to leave a comment.