Can't Clone Repository - User Not Found

Trying to clone a Git repository hosted on Space using this URL: ssh://

Is git the correct user to use? Appears as though git is able to establish contact with the repository however the user isn't found.


I think this is the problem

I'm using 1Password as SSH key agent and I can't configure which key to use for which host/user combination. It tries one at a time, which doesn't seem to work with Space as it aborts after the first try :/

Works flawlessly for both GitLab and GitHub, is there any way to work around the issue in Space?

Did it by saving the public key from 1Password to a file in ~/.ssh and adding this to ~/.ssh/config:

  IdentityFile ~/.ssh/<filename>.pub
  IdentitiesOnly yes


Same problem here. No matter what is set up as SSH keys, it won't be accepted.


Can't clone or push to repo as well. "User not found" is answer. Keys are created from recommended string under the spoiler in Git SSH Keys & HTTP Password > Quick help. Is it unavailable feature? 



Thanks for the feedback. I apologize for any way in which we may have inconvenienced you.

Could you please check that you are in a Project Member group:

Let us know if it helps you. 



Kirill Falk
The Drive to Develop

Any updates on this issue?


Hi Aien,

Please accept my apologies for any inconvenience caused. Our engineers have already prepared the bug fix that should resolve this issue, it's going to be deployed soon.

Should you have any additional questions, feel free to submit a support request.



Pavel Boger
The Drive to Develop



I just had the same problem (many months later).  I am the only person in the project. Is this supposed to be fixed?


some months later, I can't mirror my github. token is set with green check, i'm only person on project. how to fix it?

EDIT: I have to remove repository and add new one with option to mirror github, it wasn't possible to mirror on existing repo



Thank you for reaching out to us!

We have this task in the backlog please feel free to upvote SPACE-15612 Provide the ability to "Mirror from GitHub" for the existing Space repository.

If any help is still needed with your case please feel free to submit a support request.


Margarita Kolotilova
The Drive to Develop


Hello, I'm trying Space for the first time and I have the exact same issue. I create an SSH Key pair (Ed25519 and RSA tried), add the public key to my authentication tab and try pushing/cloning but only get this error:

git push origin master
fatal: not permitted. Cannot find user by credentials SSH(7d:ba:f7:77:57:20:38:c1:ae:13:c8:ce:69:85:b3:1c)
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

Using the same key with a repository on my GitLab instance works just fine (so my ssh key agent is not the problem).

What can I do to get this working?


Merlin - hi,

Could you please do the following:

  • Navigate to My Profile -> Authentication -> GitKeys and verify that added SSH key has exactly the same fingerprint as the one from the error message 7d:ba:f7:77:57:20:38:c1:ae:13:c8:ce:69:85:b3:1c
  • If they match please check that your Space user has access to the Space project that contains the necessary repository and permissions are suffiсient (e.g. the user has a Project Member role and Admnistration -> Roles -> Project Member allows to Read/Write Git repositories)
  • If they do not match please setup your SSH client to use the correct key

If points above don't help please create a support request via this link and we'll investigate your case individually.

Margarita Kolotilova
The Drive to Develop


Hi Margarita Kolotilova, I am having a similar experience to Merlin Westphal and believe this is likely a bug. 

When testing in parallel between Github and Jetbrains spaces... If I copy and paste my public SSH key to Github, it works just fine. However if when I copy the SSH key into Jetbrains Spaces, the fingerprint on the server mismatches with what Jetbrains Spaces has picked up.  This is very frustrating, I wanted to set-up a simple deployment pipeline this evening and I've fallen at the first hurdle. 

This also works just fine for Bitbucket, which is what leads me to the conclusion that it is a bug. I haven't tested against SPACE-6919 but it does sound likely that this is the issue, it would explain why the fingerprints are consistently different no matter what key I put in. 

Please work to resolve ASAP, I have been recommending Jetbrains Spaces at work, but if we were to migrate to it today, we would not be able to use it for anything. 


Same problem here with 1password and Space combo. It works well with Gitea and Bitbucket, too but not with Space. Please resolve this problem ASAP because I can't clone my repo. 


I have tried what Merlin Westphal suggested and it's working for me, too.


Hello everyone!

Merlin Westphal - thank you for posting the solution here.

This instruction can also be found inside the Space app. Please navigate to your profile -> Authentication -> Git Keys tab, then scroll to the bottom of a page and expand the "How to supply the right SSH key when several keys are present" section of Quick Help.


I followed the instructions in the Quick Help and it still does not work.  The public keys do not match what Space has saved.

EDIT: Pasting the key was the issue.  I uploaded the public key instead and it worked.


Please sign in to leave a comment.