ON_PREM: Uploading pictures/files fails

Current version: 2023.1 (build 684)

When we try to upload images it mostly fails silently. The UI will show the placeholder and uploadprogress then fail without any feedback to the user. When I tried the same in Space running as a webpage I could see in the web-console that there was a error code produced stating that filesize was too large.  The current limit is too low to work in practice.

Is there a way to configure the upload filesize limit?


Per-Olof Bengtsson, could you please elaborate what is the size of the file you tried to upload? Please also check the logs of the Space installation and let me know if any corresponding errors appear there. Thanks!


Image was around 2MB.

Server logs had no change during the test.

Browser console log was:

Failed to load resource: the server responded with a status of 413 (Request Entity Too Large)


Thanks for clarifying! Is it a Docker Compose or Kubernetes installation?

I had similar issue.
I couldn't upload any file.
In my case it was a lack of buckets in the MinIO.


Per-Olof Bengtsson may I ask if you have any web server/reverse proxy configured in front of the Space installation? Did you perform any configuration adjustments? If yes, please share more details. Thanks!


Yes, there is an nginx as reverse proxy two handle TLS/HTTPS.
This is how it was setup initially, but maybe there is a better/"native" way to enable HTTPS/TLS in space?

Looking at the Space documentation on Jetbrains webpages I have been unable to find any info on on-premises HTTPS config. Maybe I am overlooking some information?


Per-Olof Bengtsson, it's absolutely fine to use Nginx in your case, but there could potentially be a misconfiguration that leads to this issue. May I ask you to check if the issue persists when accessing Space installation directly? Thanks!


Updated our Space installation to the 2023.1.1 release and now uploading images works in the chats. I haven't tested in all different situations where upload is possible. But the latest release fixed, an important part of the issue, if not the whole. 

Update: 2023-04-12

There was still an issue with uploading files larger than a certain (not established) size. Problem was nginx default setting for `client_max_body_size ` which was capping requests with 413 error that in many situations didn't show up in logs or consoles.
Solution is to set `client_max_body_size` for the http, server or location blocks in the relevant nginx configs.
Value 0 means no max size enforced.


Thank you for the update!

Pleas let us know if you notice any problems.

Margarita Kolotilova
The Drive to Develop

Please sign in to leave a comment.